Dashboard access issue
Incident Report for AdMobilize
Resolved
This incident has been resolved.
Posted 2 months ago. Feb 18, 2019 - 14:47 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 2 months ago. Feb 16, 2019 - 21:24 UTC
Investigating
We are currently investigating this issue
Posted 2 months ago. Feb 16, 2019 - 20:41 UTC
This incident affected: Dashboard.