Dashboard access issue
Incident Report for AdMobilize
Resolved
This incident has been resolved.
Posted about 1 month ago. Aug 15, 2019 - 22:07 UTC
Investigating
We are currently investigation issues accessing our dashboards.
Posted about 1 month ago. Aug 15, 2019 - 16:17 UTC
This incident affected: Dashboard and API.