Platform Maintenenace
Incident Report for AdMobilize
Resolved
Maintenance has been completed.
Posted about 3 years ago. Mar 09, 2016 - 20:39 UTC
Investigating
Our platform is under maintenance for few minutes, no data will be affected or lost.
Posted about 3 years ago. Mar 09, 2016 - 17:39 UTC