Dashboard access issue
Incident Report for AdMobilize
Resolved
Dashboard operational
Posted over 1 year ago. Nov 20, 2017 - 22:55 UTC
Identified
Currently experiencing issues accessing the dashboard. Service provider has identified a problem and currently working to restore service.
Posted over 1 year ago. Nov 20, 2017 - 21:37 UTC