Dashboard access issue
Incident Report for AdMobilize
Resolved
This incident has been resolved.
Posted Sep 19, 2019 - 19:38 UTC
Investigating
We are currently investigation issues accessing our dashboards.
Posted Sep 19, 2019 - 16:41 UTC
This incident affected: Dashboard and API.