Dashboard access issue
Incident Report for AdMobilize
Resolved
This incident has been resolved.
Posted Mar 10, 2020 - 20:35 UTC
Investigating
We are currently investigation issues accessing our dashboards.
Posted Mar 10, 2020 - 18:58 UTC
This incident affected: Dashboard.