Dashboard access issue
Incident Report for AdMobilize
Resolved
This incident has been resolved
Posted 4 months ago. May 16, 2019 - 15:22 UTC
Investigating
We are currently investigation issues accessing our dashboards.
Posted 4 months ago. May 15, 2019 - 20:12 UTC
This incident affected: Dashboard and API.