Delays in data processing
Incident Report for AdMobilize
Resolved
Data processing back to normal
Posted almost 4 years ago. Oct 16, 2015 - 22:33 UTC
Investigating
Currently investigating issues on dashboard data delays.
Posted almost 4 years ago. Oct 16, 2015 - 16:52 UTC