Dashboard access issue
Incident Report for AdMobilize
Resolved
This incident has been resolved.
Posted 30 days ago. Aug 21, 2019 - 16:48 UTC
Investigating
We are currently investigation issues accessing our dashboards.
Posted 30 days ago. Aug 21, 2019 - 15:16 UTC
This incident affected: Dashboard and API.