Dashboard access issue
Incident Report for AdMobilize
Resolved
Dashboard is fully operational.
Posted Jan 07, 2019 - 18:38 UTC
Investigating
We are currently investigating this issue.
Posted Jan 07, 2019 - 15:21 UTC
This incident affected: Dashboard.