Dashboard access issue
Incident Report for AdMobilize
Resolved
The incident has been resolved
Posted 3 months ago. Jan 30, 2019 - 14:49 UTC
Identified
We are currently experiencing access issues to the dashboard.
Posted 3 months ago. Jan 29, 2019 - 15:20 UTC
This incident affected: Dashboard.