Delays in data processing
Incident Report for AdMobilize
Resolved
system is operational
Posted over 3 years ago. Dec 22, 2015 - 14:11 UTC
Investigating
Delays in data processing, due to issues with tasks processing vendor.
Posted over 3 years ago. Dec 21, 2015 - 15:56 UTC