DNS outages reported worldwide
Incident Report for AdMobilize
Resolved
This incident has been resolved.
Posted almost 3 years ago. Oct 24, 2016 - 13:18 UTC
Identified
Possible difficulties using the platform due to DNS attacks happening worldwide.
Posted almost 3 years ago. Oct 21, 2016 - 20:57 UTC