Currently experiencing delays in data processing.
Incident Report for AdMobilize
Resolved
Processed data up to date
Posted over 3 years ago. Oct 13, 2015 - 16:28 UTC
Investigating
Currently experiencing delays in reporting data to the AdDashboard.
Posted over 3 years ago. Oct 12, 2015 - 13:53 UTC